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Configuring Android Application Development

Environment

What is Android SDK ?

v" The Android SDK includes a complete set of development tools. It includes a debugger, libraries,
a handset emulator.

v Software written in Java can be compiled to be executed in the Dalvik virtual machine, which is a
specialized VM implementation designed for mobile device use.

Required Software to Install Android ?

1. JDK6 Version
2. Android SDK for Windows (if you have Windows OS)
3. Eclipse IDE

Installing JDK6 (Java Development Kit)

The latest version of jdk is 6, at the time of writing my java tutorial. We can
download thejdk from:
http://www.oracle.com/technetwork/java/javase/downloads/index.html.

%) Java SE Downloads - Mozilla Firefox

File Edit View History EBookmarks Tools  Help
[®] 1ava SE Downloads | + |

= | vy aracle.com]technetwork javaliayase/ downloads inde:x, bt

feature ar technigque and has been deliberately
simplified.

\/ JDK JRE
THiS FETEREETIAes 1aols useful far
developing and testing programs written in the
Java programming language and running on the

Java™ platfarm. Learn mare » JDK 6 Docs JRE 6 Docs
Cliek here to start to . Installatinn . Installaﬁun
. Instructions Instructions
download .exe file
* Readhie * Readhie
* ReleaseMotes * ReleaseMotes
* Oracle License * Oracle License

Step 1. Once we download the exe file we can now install it. Just follow what i
mentioned below: To install the jdk, double click on the downloaded exe file (jdk-6ul-
windows-i586-p.exe) Double Click the icon of downloaded exe from the downloaded

location.

Tywpe: Spplication
Size: 56.0 MB

You will see jdk 6 update 1 window as shown below.
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Java({T™) SE Development Kit 6 Update 1

El, Pleaze wait while ‘Windows configures JavalTk) SE Development
I. E‘:‘ kit B Update 1

Gathering required information. ..

i

Java({T™) SE Development Kit 6 Update 1

» E| Fleaze wait while Windows configures JavalTh] SE Dewvelopment
J=F Kits Update 1

Gathering required informatiar...

lﬁ Cancel |

Step 2: Now a "License Agreement" window opens. Just read the agreement and

click "Accept" button to accept and go further.
x|

License Agreement

Please read the Following license agreement carefully, 0
Sun.

Sun Microsystems, Inc. Binary Code License Agreement ﬂ

for the JAVL 3E DEVELCPMENT KIT (JDE), VERSION o

SUN MICROSYSTEMS, INC. (™3UN") IS WILLING TO LICENSE THE
SOFTWARE IDENTIFIED BELOUW TO YOU ONLY UPON THE CONDITION
THAT ¥OU ACCEPT ALL OF THE TEEM3 CONTAIMED IMN THIS

BEINALRY CODE LICENSE AGREEMENT AND SUPFLEMENTAL LICENSE
TERMZ (COLLECTIVELY "AGREEMENT™).O PLEASE READ THE
AGREEMENT CAREFULLY.O BY DOWNLOADING OFR INSTALLING THIS
SOFTWARE, YOU ACCEPT THE TERMS OF THE AGREEMENT.

INDICATE ACCEPTANCE BY SELECTING THE "ACCEPT™ EUTTON AT

THE EBOTTOHM OF THE AGREEMENT. IF ¥OU ARE NOT WILLING TO

BE BOUND EY ALL THE TERMZ, JELECT THE "DECLIMNE"™ BUTTON :J

fccept >

Step 3: Now a "Custom Setup" window opens.

i'é‘- Java({TM) SE Development Kit 6 Update 1 - Custom Setup |

Custom Setup

Select the program features you want installed, 0
Sun.

Select optional Features to install from the lisk below, ou can change your choice of Features after
installation by using the Add/Remove Programs utility in the Control Panel

—Feature Description

Java(TM) SE Development kit &
Update 1, including private JRE &
Update 1. This will require
Source Code 300ME on your hard drive.

Public JRE

Demos and Samples

Install o

C:YProgram Files)Javaljdkl.6.0_01% Change... |

< Back I Mext = I Cancel |

Step 4: Click on "Change" button to choose the installation directory. Here it is
"C:\Program Files\ Java\jdk1.6.0_01". Now click on "OK" button.
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i'-§' Java(TM) SE Development Kit 6 Update 1 x|

Change Current Destination Folder
Browse to the destination Folder, 0

Look in:

£ jdk1.6.0_01 j ﬂ

Eolder name:

Ok I Cancel |

Clicking the "OK" button starts the installation. It is shown in the following

figure.

i'é‘- Java(TM) SE Development Kit 6 Update 1 - Progress = |E||5|

Installing
The program Features vou selected are being installed.
@ Sun.

Flease wait while the Instal Wizard installs 1avaiTM) SE Development Kit &
Update 1. This may take several minutes.

Status:

Generating scripk operations For action:

Step 5: Next window asks to install Runtime Environment.

i3 Java(TM) SE Runtime Environment 6 Update 1 - Custom Set x|

Custom Setup
Select the program Features you want installed. 0
Sun.

The JavaiTM) SE Runtime Environment with support For European languages will be installed, Select
optional Features to install from the lisk belaw,

~Feature Description
Ia
. The Java(TM) SE Runtime
= -| Additional Languages Environment with European
<=8 = | Default Java For Internet Explorer languages. This requires 143ME on
- (=3 ~ | Additional Font and Media Support your hard drive.

Install to:

C:iProgram Files)Javaijrel 6.0_01%
Change. .. |

InistallShield
Mext = I Cancel |

Click the "Change" button to choose the installation directory of Runtime
Environment. We prefer not to change it. So click "OK" button.
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i@ Java(TM) SE Runtime Environment 6 Update 1 x|

Change Current Destination Folder

Browse ko the destination folder.
@Sun

Loak in:

£ jrel.6.0_01 | ﬂ

Folder name:

InstallShield

Ok I Caneel |

Step 6: Click "OK" button starts the installation.
P e

Installing

The program Features you selected are being installed.
@ Sun.

Flease wait while the Install Wizard installs JavaiTM}) SE Runtime
Environment 6 Update 1. This may take several minutes.

Status:

Generating script operations for action:

Inistallshisld

Step 7: Now "Complete" window appears indicating that installation of jdk 1.6 has

completed successfully. Click "Finish" button to exit from the installation process.
x

Wizard Completed

The Inskall Wizard has successfully installed Java(TM) SE
Development Kit & Update 1., Click Finish to exit the wizard,

[w Show the readme file

Step 8: The above installation will create two folders "jdk1.6.0_01" and
"jrel.6.0_01" in "C:\ Program Files\ java" folder.
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<yProgram Files',Java

| Fie

Edt  Wiew Favorites  Tools

Help

J = Back * = - | @Searth ‘%Foldars @Histﬂf}f | iz I @ ‘ Ed-

=10 =]

J Address Ia C:\Program Files) Java

j @Go

Folders X

] ComPlus App\icat\ons;l
-] Inkel
-] Intermet Explarer
[#-423 Java
-] microsoft frontpage
£
£

7] Microsoft Office

-] Micrasoft Visual Studi

i {j MetMesting b
(7] Outlook Express

-] snapshot viewer

-] Trend Micro =
P e deem Mo i P
4| [ v]

@ @

jdk1.6.0_ 01 jrel.6.0 01

|2 objectis) (Disk free space: 16.2 GE)

‘D bytes | [y Computer

Installing Android SDK Tools &API ?

Step-1) Download Android SDK from http://developer.android.com/sdk/index.html,

as | shown below.

?) Android SDK, | Android Developers - Mozilla Firefox

Ble Edt View History

Bookmarks  Tools  Help

| Android SDK | Android Developers

[+]

(- @ developer.andraid.com/sdkjinde:. html#Requirements

¢ | ‘ S ™ My Wieb Search

We will get the downloaded exe file, as

MVGRCE

W Developers v Design  Develop  Distribute Q | :
Android Training API Guides Reference Tools
Developer Tools Get the Android SDK
Download A
E The Android SDK provides you the APl libraries and

Installing the v
SDK

Exploring the SDK
NDK

Workflow v

4

Tools Help

Davisinne

developer tools necessary to build, test, and debug
apps for Android.

Download the SDK for Windows

Other platforms | System requirements
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J File Edit “iew Fawvorites Toaols Help
= [ x e

J O Back ~ () ~ ir | /-- ! Search Falders

J address I_} Fivandroid SoftwarehMallikarjun

inskaller _r15-windows

]\ Double Click to install.,

Step-2) Double click on SDK Installer.exe file to install

Open File - Security Warning ﬂ

The publizher could not be verified. Are you sure you want to
run thiz zoftware?

Mame:  installer_r18-windows,exe
Publizher,  Unknown Publizher
Type: Application
From: Fi\android Soft

Run | Cancel I
V¥ Zlways ask before opening this file /\

This file does not have a valid digital signature that verifies its
publisher. *¥'ou should only run software from publizhers you tust.
How can | decide what software to un?

@ Android SDK Tools Setup P ] [

Welcome to the Android SDK Tools
Setup Wizard

This wizard will guide you through the installation of Android
SDK Tools,

It is recommended that vou close all other applications
before starting Setup, This will make it possible to update
relevant system Files without having to reboot your
compuker,

Click Mext bo continue,

Mext = I Cancel

Click on Next button
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@® Android SDK Tools Setup

Java SE Development Kit
Detect whether Java SE Development Kit is installed.

Android SDK relies on the Java SE Development Kit (D).
Java SE Development Kit (IDK) version 1.6 has been found.

Location: C:\Program Files)Javaljdkl.6.0_20\bin\java.exe

Tullsoft Install Systenm wB0-Mar-2012, cvs

< Back I Mext = I Cancel
Click on Next button
@® Android SDK Tools Setup - |EI|1|
Choose Install Location Fmr
Choose the Folder in which to install Android SOK Tools, E @)

Setup will install Android SDK Tools in the Following Folder, To install in a different Folder, click
Browse and select another folder, Click Mext to continue,

Destination Folder

It \Program Filestandroidiandroid-sdk

Browse... |

Space required: 54, 7ME
Space available: 2.8GE

Iullsaft Install System w30-Mar-2012, cys

< Back I Mext = I

Cancel |

Step-3) Ensure Destination Folder, and click on Next button

@® android SDK Tools Setup P ] 5|
Choose Start Menu Folder L
Choose a Start Menu Folder for the Android SDK Tools shorkouts, I

Select the Start Menu Folder in which ywou would like to create the program's shortcuts, You
can also enter a name to create & new folder,

Accessaries -
Administrative Tools

Android SDK Tools

Apache Tomcat 6.0 Tomcats

avast! Free Antivirus

AVG 2011

Canon MPZ50 series

Canon MPZ50 series Manual

Canon Utilities

EditPlus 3

Games LI

[” Do rot create shorteuts
Tullsaft Install System vE0-Mar-201 2, cvs

< Back I Install I

Cancel |

MVGRCE
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Click on Install Button

@ Android SDK Tools Setup

Installing
Please wait while sndroid SDK Tools is being installed.

Extract: jwthaon.j

Extrack: guavalib.jar... 100%

Extract: hardware-properties.ini... 100%
Extrack: hierarchyviewer2 jar... 100%:
Extract: hierarchyviewetlib. jar... 100%
Extrack: httpclient-4.1.1.jar... 100%.
Extrack: httpoore-4,1.jar, ., 100%
Extrack: httpmirme-4.1.1.jar... 100%
Extrack: jcormmon-1.0,12.jar,., 100%
Extrack: jfreechart-1.0.9-swt jar... 100%
Extrack: jfreechart-1.0,9.jar. ., 100%
Extrack: jsilver.jar... 100%

Extrack: jwthon.jar... 3%

Hullsaft Install System w30-Mar-2012, cvs

N

< Back | flext = I

Cancel |

i @® Android SDK Tools Setup

Installation Complete
Setup was completed successfully,

Completed

|

Extract: proguardgui.jar... 100%

1 Extract: retrace.jar.,. 100%

Qutput Folder: CiiProgram Files\androidiandroid-sdkitoolssupport
Extrack: annokations.jar... 100%

Output Falder: CriProgram Files\androidiandraid-sdk

Output Falder: CriProgram Files\androidiandraid-sdk

Created uninstaller: CiiProgram Files\androidiandraid-sdkiuninstall. exe

I Cutput Folder: Cii\Documents and Settingshall UsersiStart Menu\Programsiandroid S...

Completed

Iullsoft Install System wa0-Mar-2012, cvs

Create shorteut: CiDocuments and SettingsiAll Users\Start Menu\Programsiandroid ...
Create shorteut: CiDocuments and SettingsiAll Users)Start Menu\Programsiandroid ...
Create shartcut: CiDaocuments and SettingsiAll Users\Start Menu\Programstandraid ..

-]

= Back I Mexk > I

Cance] I

Click on Next button

@ roid SDK Tools Setup

=101]

Completing the Android SDK Tools
Setup Wizard

Android SDK Tools has been installed on yaur computer,

Click Finish to close this wizard,

[V sStart SDK Manager (ko download system images, etc.)

<= Back I Finish I Cance]

MVGRCE
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Click on Finish button
Step-4)installing Android SDK tools and Android API Levels.

Ensure the following installed Android SDK location in file system, and click on SDK
manager from the android-sdk directory.

[ android-sdk

J Fle Edt ‘View Favorites Tools Hep

Jaﬁack - e - lﬂ;

J fiddress |@ C:\Program Files| Andraidiandroid-sdk

IIJ add-ons I,/] platforms ‘IJ tadls 2D Manager SOK Manager
| [ |
- _

5
/- Search i Folders

='Wk X n‘v @FolderSync

-

= | 5D Readme ) \ i

{g Text Document ] g';'gsltﬂm Double Click the followin

= | 218 ge it Sereen will appear 1o install
android SOK Library

It opens the following window,

Step-5) This step is very important , from the following Window, select tools, API Levels like

API15, API 10, ..etc, and also select Extras-> Google USB Driver package for USB Connections with
real device.
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Packages Tools
SDK Path: C\Program Files (86 Androidvandroid-sdk

Packages

w Mame Rev.  Status

a 7]

Android $0K Tools S Installed
IFdl Android 30K Platform-tools + Mot instolled
o 7] (5 Apdroid 4.0.3 (AP115)
[# =l Documentation for Android SOK & Not installed
[#] B\ EDK Platjorm & Not installed
[ ™ Eomples for SDK & Not instolled
[¥] ‘& \ARM EARI v7a System Image + Mot instolled
cogle APs by Google Inc w Not inshalled
ofs for Androig SOK & Not installed
. 7[5 Android 4.0 (APT14)
| ! Android 3.2 (AP[13)
. (% Android 2.1 (AP[12)
1 (551 Aenelemial 37 FADET1Y

Show: || Updates/New [J|Tnstalled || Obsolete Select Mew or Updares Install & packages...

Sort by: @ APT level 1 Repositary Deselect All Delete 1 package...

=
Done loading packages.

Click on Install XX Packages button.

i Choose Packages to Install =10l x|

- Packages ~Package Description & License
b Android SDK Toals, in 20 Package Description -

 Android SOK Platform-tools, revision 12 [*] Android SDK Tools, revision 20

This update will replace revision 16 with revision 20,

Dependencies
Installing this package also requires installing:
- Android SDK Platfarm-tools, revision 12

Archive Description
Archive For Windows

Size: 86.1 MiB
SHAL: Fastech7haf79e33e0b0cshite 34505465 0790 Fa
f‘(".. .
v Accept Reject " accept All

1 2

[*#] Samething depends an bhis package { Inskall ! ) Cancel

Be patient Installation will start will take more time..

Installing Eclipse & Configuring Android Plugin for Eclipse :

MVGRCE COMPUTER SCIENCE AND ENGINEERING



Mobile Application Development Lab Manual

Configuring Android Tools for Eclipse:

Step-1) Download eclipse software from www.eclipse.org\downloadslocation.

[ Eclipse Dawrloads I + I
(' & ww edlipse.orgldownloads/ a ‘ ‘ + 7 My Web Search
@ Visit other Eclipse Sites
- NS ]
@) .
»n§ 08208
Home  Downloads  Users  Members  Committers  Resources  Projects  About Us Custom Search Search
Eclipse Downloads
Packages Projects W Follow @EclipseFdn  [ELike zsk
LN windows — =[) Installing Eclipse
I8 Eclipse IDE for Java EE Developers, 121 e Windows 32 Bit 0 MERN@CD
bsy Downioaded 1 362568 Tz Details Windows 64 Bit » Compare/Combine Packages
u Known Issues
. Eclipse Classic 4.2 182mp Windows 32 Bit u Updating Eclipse
Downloaded 1,002,545 Times Details Other Downloads Windows 64 Bit
4 Eclipse IDE for Java Developers, 143 w5 Qwﬁuws 32 Bit
Downloaded 559315 Times Details Windows 64 Bit

Step-2) Confirm the downloaded .zip file location, and decompress using either
winzip (or) winrar software.

& Mallikarjun

J File Edt Wiew Favorites Tools Help
J@Backvovl_ﬁ? = & Xz)|*
|

Address I[ﬁ Fihandroid SoftwareiMallikarjun

-

j_jSearch i Folders

L

T edipse-java-indigo-3R.1-win32
i eclipse-java-indigo-3R.1-win32 WiNRAR archive
L 164,215 KB

Decompressed folder of Eclipse bownloaded .zip file of Eclipse

Step-3) Open Eclipse.exe file, from the file system location.
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J Address I"j F:android Soft\eclipse-jawa-indigo-SR1-win32\eclipse-java-indigo-SR1-win32ieclipse

5 epl-+10 (g)Scan eclipse.exe
E]natice | gl Scan with Avs
EditPlus 3
B add ko archive...
B add ta "eclipse.rar”
B Compress and email. ..
I Compress ko "eclipse.rar" and email

Send To [ 3

Zuk
Copy

Creake shorkcuk
Delete
Renames

Properties

Mame = I Size I Tvpe I Date Modified
I configuration File Folder g/16/2012 1:48 PM
I dropins File Folder Q15/2011 10:00 PM
[Cifeatures File Folder 2I27I2012 12113 AM
Cpz File Falder 9152011 9:59 PM
I plugins File Folder ZIZFIZ01Z 12:08 AM
ICreadme File Folder Qf15/2011 10:00 PM
.eclipseproduct 1 KB ECLIPSEPRODUCT File 72902010 10;36 AR
artifacts 102 KB =ML File 2I27I2012 12:13 AM
eclipse 52 KB aApplication 302142011 4:05 PM
__.'}eclipse Configuration Setkings 22702012 12:13 AM
Eeclipsec Run as... Application 32102011 4:05 PM

HTML Docurment
ML Docunenk

2{25/2005 6:53 PM
2/4/2011 3139 PM

Open eclipse.exe application file

Step-4) Configruing the ADT Plugin :

e Start Eclipse, then select Help>Install New Software.

& lava - Eclipse

9= -

Fle Edit Run Source Mavigate Search Project Refackor  Window | Help

J D J L1 J{Jg JE' ki Jﬁ ,':D%:W"."elcome J

[ Package Explarer £3 =8

@ Help Contents

| =

Select Help- > Install New Software |
v SoTiware

47 search i
Dynamic Help

Key Assist... Chrl+Shift+L
Tips and Tricks. ..
;f Repatt: Bug or Enhancement...

Cheat Sheets. ..

Check for Updates
Install i
Eclipse Marketplace. ..

About Eclipse

MVGRCE
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L install

Awvailable Software

Select a site or enter the location of a site.

‘Work with: I https:{dl-ssl.google, comfandroid/eclipse/

Find more software by working with the 'Available Software Sites' preferences.,

Itype filker bext

Mame

x|
I

2
0@ There is na site s Mame: Sl zndroid Plugin_

Local... |

LocationqEtt_Es:,l’,l’dl-ssl.google.com,l’android,l’eclipsez -
3

Archive. ., |
== =
T D o |

"Details

[V shaw only the latest versions of available software

v Group items by category

[V Cortact all update sites during install to find required software

[ Hide items that are already installed
What is already installed?

= Back. | Iexk = | Finiisti I

Cancel

e Click Add, in the top-right corner.
e Inthe Add Repository dialog that appears, enter "ADT Plugin" for the
Name and the following URL for the Location:
https://dl-ssl.google.com/android/eclipse/

e Click OK.

If you have trouble for the plugin, try using "http" in the Location URL,

instead of "https" (https is preferred for security reasons).

MVGRCE
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LFinstall =] 3]
Available software
Check the items that wou wish ta install, —
ey -

okl with: I https:/ dl-ssl. google. comfandroidfeclipse j Add... |

Find more software by working with the 'Awvailable Software Sites' preferences.

Itype filter text

b I Version I
O Pending ®

r—Details
el
=5
W Show only the latest versions of available software [ Hide itemns that are already installed
¥ Group items by category What is already installed?

V¥ Cortact all update sites during install to find required software

= Back | fiext = | Finist I Cancel |

e Inthe Available Software dialog, select the checkbox next to Developer
Tools and click Next.
¢ Inthe next window, we'll see a list of the tools to be downloaded. Click

Next.
_iBix
Available Software
Check the itemns that vou wish to install.

=y =

ok with: I https:ffdi-ssl.google . comyandroid/eclipse/ j Add... |

Find mare saftware by working with the ‘Available Software Sites' preferences.

|type filker kexk

[ | Yersion |

Ei - 000 Developer Tools =1
000 WDK Plugins

r~ Details
==
o |
[ Show orly the latest versions of available software [ Hide items that are already installed
¥ Group items by category What is already installed?

v Contact all update sites during install to find required software

a2
=

o,
@) = Barl (I Mext = I) Fimish Cancel
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e Click on “Next” button

N =0

Available Software

Check the items that you wish o install, ) |
ey

Wik with I https: fidl-ssl, google.comyandroidieclipse j Add, ., |

Find more software by warking with the ‘Available Software Sikes' preferences.

Itype filker text

Marne | ersion |
000 Developer Tools
000 MEK Plugins

- Details
==
==
¥ | show only Ehe |atest versions of available soffware I™ | Hide items that are already installed
¥ Group ibems by, cateqory: What is already installed?

¥ | Cortact all update sites duting install o find required|software

Calculating requirements and dependencies,

@j < Bach: I ek = I Finiisti | Cancel

e Read and accept the license agreements, then click Finish.

e [f you get a security warning saying that the authenticity or validity of the
software can't be established, click OK.

e When the installation completes, restart Eclipse.

Configuring the ADT Plugin for Eclipse :

After we've installed ADT and restarted Eclipse, we must specify the location of our
Android SDK directory:

1. Select Window>Preferences... to open the Preferences panel (on Windows OS X,
select Eclipse>Preferences).
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& lava - Eclipse

File Edit Run Source Refactor Mawvigate Search  Project | window Help

=& = . Mew Window - = 2
== N B=RIR= RN _ G-|le®=o -
[{ew Editar
% Package Explarer 53 =0
Open Perspective 4
0 & | =~ '
= | @ Shiow Yiew 4

Cuskomize Perspective. .,
Save Perspective 4s...
Reset Perspective. ..
Close Perspective

Close all Perspectives

Mavigation 4

Android SDE Manager

m aYD Manager T
[ Run Android Lint )

\ Enure after restart

Now, Select Window- »Preferences

2. Select Android from the left panel.
You may see a dialog asking whether you want to send usage statistics to Google. If

so, make your choice and click Proceed.

3. Forthe SDK Location in the main panel, click Browse... and locate your downloaded
Android SDK directory (such as android-sdk-windows).
4. Click Apply, thenOK.

Click Ap
Jercrene i

| |tvpe filker text Android = -
1 Android Preferences E 2

- Build SOk Location: I ZiiProgram Filesyandroidiandroid-sdk. \/ ( Browse, .. | :
E;:lﬁrs Mote: The list of SDK Targets below is only reloaded once you hit 'Apply' or 'Ok’
e Launch Targek Mame | ‘endor | Platfarm | APT ... |
i Link Errar Checking Android 2.3.3 Android Open Source Project 2.3.3 10
i LogCat #Android 4.0 Android Open Source Project 4.0 14
‘... Usage Stats Android 4.0.3 Android Open Source Project 4.0.3 15

[+ &nk

[ Help

[ InstallfUpdate

[ Java

[#-Maven

- Mlylyn

[ Run/Debug

[+ Team

[+ Usage Data Collector

- \alidation
- WindowBuilder
[#]- ML

3
Restore Defaulks | c Apply i
= 4
@jl < CK I »  Cancel |
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Note :“With this your Android Installation part is completed, we can configure
Android plugin for other IDE’s like Netbeans, IntelliJ IDE also. “

What is AVD ? How to Configure AVD?

v" AVD, stands Android Virtual Device, AVD’s are used to start emulator. When we launch
the emulator, we should specify the AVD configuration that we want to load..

v Before Configuring AVD, first confirm SDK tools and API levels are installed or not !

v' Then select AVD Manager from Window -> AVD Manager.

& Java - Eclipse

File Edit Run Source Refactor Mavigate Search  Project | Window Help

|59 - |8 B & | & 5 (e Windw c}
e Edibor

Sy

-
[% Package Explarer &3 =0

-

Open Perspective
o
= <EE> | = Shaw Wigw k

Customize Perspeckive. ..
Save Perspective As. ..
Reset Perspective. ..
Close Perspective

Close all Perspectives

Mavigation L

android S0F Manager
Select Window- > AVD Manager :; B 2D Manager

[ Run &ndraoid Lint
Preferences

List of existing Android Virtual Devices located at C:\Users\user\.android\avd

AVD Name Target Name Platform API Level CPU/ABI

No AVD available

~ Avalid Android Virtual Device. .| A repairable Android Virtual Device.

X An Android Virtual Device that failed to load. Click 'Details' to see the error.
s =
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v Click New... button, name your new AVD, select API target, SD Card size, then click
Create AVD button

Name: Android|

H Target:  |Android 4.0.3 - API Level 15 -
CPU/ABL | ARM (armeabi-v7a)
SD Card:
© Size: 512
() File: Browse..
Snapshot:
"] Enabled
Skin:
© Built-in: [ Default (WVGAS00) v
() Resolution: X
Hardware:

Property Value

Abstracted LCD density 240
Max VM application hea... 48
Device ram size 512

Override the existing AVD with the same name

[ Create AVD ][ Cancel ]

v' Click Start... button to start your new AVD. It will takes a few minutes for creating
new AVD.

Tools

List of existing Android Virtual Devices located at C:\Users\user\.android\avd

AVD Name Target Name Platform API Level CPU/ABI
7 Android Android4.03 403 15 ARM (armeabi-via)

m| |2

Delete...

Repair.

Start...

]

Refresh

~ Avalid Android Virtual Device. || A repairable Android Virtual Device.
X An Android Virtual Device that failed to load. Click 'Details' to see the error.

What is Emulator ? How to Start ?

v' The emulator lets you prototype, develop and test Android applications without using a physical
device.
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Mobile Application Development Lab Manual

v" To use the emulator, first we must create AVD configuration, Remember, If project is used with
Android API15 level , then we should use AVD API level also 15.

v" Every Emulator needs one AVD support, because the AVD configuration provides both software
and hardware support for Emulator, like it can use the services of the Android platform to invoke
other applications, access the network, play audio and video, store and retrieve data, notify the
user, and render graphical transitions and themes.

v' The emulator also includes a variety of debug capabilities.

v' The emulator provides dynamic binary translation of device machine code to the OS and
processor architecture of your development machine.

v" The Android emulator contains all of the hardware and software features of a real mobile
device, except that it cannot place actual phone calls, can’t carry.

v' Emulator provides a screen like as real device to display output of our testing application, using
this we can easily test our applications.

0 [ [ P e e poves ey ey

Voot BmSRTRSS Y  B
r;"—'r‘- - "',r"“'

MVGRCE COMPUTER SCIENCE AND ENGINEERING



